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Spell Checking Text

FormFlow includes a spell checker to ensure that all the data you enter in your form is spelled correctly. You can check the entire record or individual form fields.

To spell check a field or record

1. Tab to or click in the field you want to check.
2. On the Tools menu, click Check Spelling. FormFlow compares the text in the field with the entries in two dictionaries: the default dictionary and your custom user dictionary. If everything in the field matches something in one of the dictionaries, a message appears:

Spell check for current field complete. Continue checking for the rest of the form?

To check other fields, click Yes.

To end spell checking, click No.

Working with Databases

Before you can add new records or view existing records in a form, you must open a database.

Opening a Database

You can open a database in either of two ways:

Method #1 - Open a database for the current session only. When you finish the current session, and close the form, there is no further association between the form and the database. To use the same database in subsequent sessions, you must repeat the process of opening the database.

Opening a Form and Data File

1. Open the form you want to work with by selecting File Open.  Select the drive and folder that your form is stored in and select OK.  If the form is not there you can download it (Save To Disk) from the Electronic Forms and Publications web page at http://www.afmc.wpafb.af.mil/pdl/forms/ to your forms folder on your hard drive.



2. The first time you open a new form you will see the following question.  Please respond NO to this.



3. On the Data menu, click Open Data. The Open Form Databases dialog appears.



4. Click in the Format box, scroll through the list of database formats, and then click the format you want. This is usually ASCII or dBase.

5. Select the Browse button to specify the drive, directory and file name of the database file you want to open, then click OK to return to the Open Form Databases dialog.



6. In the Open Form Databases dialog, click OK. FormFlow opens the database.

Method #2 - RECOMMENDED METHOD - Open a database and define it as the default database for the form.  When you finish the current session, and close the form, FormFlow retains the association between the form and the database. The next time you open the form, FormFlow automatically opens the default database.

Opening a Form and Defining a Default Data File

1. Open the form you want to work with.  See Steps 1 and 2 from Method #1.

2. On the Data menu, click Default Data.



3. Click in the Format box, scroll through the list of database formats, and then click the format you want. This is usually ASCII or dBase.

4. Specify the drive, directory and file name of the database file you want to create, then click OK to return to the Form Default Databases dialog.



5. In the Form Default Databases dialog, click OK. FormFlow opens the database.  NOTE:  If the database does not exist, a confirmation dialog appears, to verify that you want to create it. Click Yes to create the new database. An information dialog appears, showing details of the newly created database.



6. A further dialog appears stating the database has been created.  Click OK.



7. A further dialog appears, asking if you would like to open the new default database now.  Click YES.



From this point on everytime you open this form it will automatically open your default data.  WARNING:  Please make sure that you create/save your database in a folder that already exists.  If you do not, you will get no error messages but your data will not be saved.

Saving A Database With A Different File Name Or A Different Path

When you save a database with a different file name or a different path, you create a copy of the original database in the new location. You can then modify and save data in the new database without altering the original file.

1. Open the form with the database you want to modify.  (See the Working With Databases section)

2. On the Data menu, click Save Data As. The Save Data As dialog appears.

3. In the Current database list, click the database you want to save to a different name.

4. Click in the Database file box, type the new path and file name, and then click OK.

5. If the database does not exist, a confirmation dialog appears, to verify that you want to create it. Click Yes to create the new database. An information dialog appears, showing details of the newly created database.

6. A further dialog appears, asking which records you want to save to the new database. Click either of the following:

Current – to save only the current record to the new database

All records – to save all existing records to the new database.

Note: To save a copy of a database on a network drive, you must have write access. If FormFlow cannot create a database for you, check that you have write access on the drive on which you want to save the database. You also need write access on the drive, on which the form is stored, because FormFlow needs to create a file in that directory when it creates a new default database.

Merging a Database

If you have multiple databases for the same form, you can merge the files together into one database file.  

1. Open the form with the first database file.  (See Method #1 in Working With Databases section)

2. Click File and Append To from the menu.

3. Click in the Format box, scroll through the list of database formats, and then click the format you want. This is usually ASCII or dBase.  Select the Browse button to specify the drive, directory and file name of the database file you want to append to (merge into), then click OK to return to the Open Form Databases dialog.



4. If your first database file had multiple records, you will be prompted to click either of the following:

Current – to save only the current record to the new database

All records – to save all existing records to the new database.

Working with Records

Creating a New Record

When you first open a form that has existing records in the attached database(s), FormFlow displays one of the existing records. Before you begin filling, you must create a new, blank record.

To create a new record from a blank record

On the File menu, click New. A blank copy of the form appears, ready for you to fill.

Making a Copy of a Filled Record

Once you have filled a record and you want to make a copy of this record with a few modifications.

To add a filled record

1. Open the record you want to copy.

2. Fill the fields on the record and make any modifications desired.

3. On the Data menu, click Add Record.

4. Click Add.  The filled record is added to the database, and a new, blank copy of the form appears, ready for you to begin filling the next record.

Updating an Existing Record

You can modify an existing record at any time. Once you have made the changes/additions, you must save the modified record to the database.

To update a modified record

1. Make the necessary changes to the fields on the record.

2. On the Data menu, click Update Record. The modified record is saved to the database.

Deleting a Record

You can delete an existing record from a database.

To delete a record

1. Display the record you want to delete.

2. On the Data menu, click Delete Record.

NOTE: When you delete a record from a dBase database, it remains in the file until you purge deleted records. 

3. On the Data menu, click Purge Deleted Records. A dialog appears, asking you to confirm the deletion.

4. Click Yes. The deleted records are permanently removed from the database.

Locating and Displaying Records

You can view the existing records in the database attached to a form in the following ways:  In addition to using the buttons shown in the diagram below, you can also use the Locate menu.



To go to a specific record

1. On the Locate menu, click Go To Record. The Go To Record dialog appears.

2. Type the number of the record you want to go to, then click OK. The specified record appears.

NOTE:  If you are using a multiple page form, you can quickly navigate to the other pages by using either the PageDown or PageUp keys on your keyboard.

Sending Forms via Email

You can send a form and its associated data to another person or group using your mail system as the transport mechanism. Sending forms via email is a fast and convenient way to get the form from your desk to the next person who needs to see it. When you send a form, FormFlow places the form and all the files associated with it inside a form package, which it attaches to a mail message to the recipients. Recipients can open the form package and view the form from within FormFlow, or from their mail system.

Send a form via Email

1. Open the form you want to send. If you want to send a particular record, display that record.

2. On the File menu, click Send Form.

3. If you are not logged into your mail system, the mail system login dialog appears. Type your user name and password, then click OK. The Send Form dialog appears.  Select recipients, or type the recipient’s name, then click Add.  Type a subject.  Add a Note, if required

4. Edit the subject of the form you are sending, if required. The default subject is the form’s title (if the form designer created one) or the form’s file name if the form has no title.

5. Address the form. There are two ways you can add recipients: Click Address. Your mail system’s standard Address dialog appears. Choose the names of the people you want to send the form to, then close the dialog. The names you choose appear on the Recipients list.  Type a recipient name in the To field, then click Add. Repeat until all the names you want appear on the Recipients list.  

6. In the Notes field, add a Note to accompany the form, as required.

7. Select that records you want to send with the form.

8. Specify other options as appropriate. Click the tabs at the top of the dialog to display the other options.

9. Click Send to send the form.

Note: For information about options on the Send Form dialog, see the online help. The options available to you on this dialog are controlled by the designer of the form, and can vary from form to form.

Packaging Forms (Recommended Method for Sending Files via Email)

You can package a form, its associated files, and other selected files in a single file known as a form package. By condensing all of a form’s related files into a single file, the task of moving the form from one location to another—either by email, via floppy disk, or using the DOS or Windows File Manager commands—is made easier. You need only move a single file, and the paths that reference the form’s related files are updated to reflect the new location.  Creating a form package is useful when you want to make a backup copy of a form and its related files, or if you need to move a form to another computer that is not connected to a network, and so must transfer files on a floppy disk.

To create a form package

1. Open the form you want to package. If you want to package a particular record, display that record.

2. On the Tools menu, click Package Form. The Package Form dialog appears.

3. Specify what you want to include in the package. Click each tab on the dialog and specify package options.

4. Click OK. The Save Form Package As dialog appears.

5. Specify the drive and directory where you want to save the file.

6. In the File name field, type the name you want to use for the package, then click OK.  Note: To open a form package, use the Open command on the File menu, as you would to open any form or form application.  If File Packager is defined as your mail system, you can also locate and open form packages using the Receive Form command on the File menu.

Unpacking Packages

To extract the files in a form package, you must first unpack, or disassemble the single .FPK into its original components. You can then save the files to your hard drive and edit them as required.  Your ability to unpack a package is determined by the form designer.

To unpack a package

1. Open the package in your workspace.

2. On the File menu, click Unpack Package. The Unpack Package dialog appears.

3. Specify the drive and directory where you want to save the unpacked files.

4. Specify other options, as required.

5. Click OK to unpack the package.  Note: If the Unpack Package command does not appear on your File menu, the form designer has not given you permission to unpack the package, or you are using a custom form or form application. Specify where you want to store the files.

Updating Packages

When you edit a form package you have received, FormFlow actually maintains two separate versions of the package: the original attached to the mail message you received, and the edited version. When you send the edited version, the recipient’s version and the version you received are no longer the same. To maintain only one version of a received form package, use the Update Package command to replace the package you received with your edited version, before you send it to the next recipient.

To update a package

1. Open the package in your workspace.

2. Edit the package as required.

3. On the File menu, click Update Package.

4. Close the form, or send the package to the next recipient, as appropriate.  FormFlow replaces the package you originally received with the updated version. If you reopen the package, it contains the changes you made.

Forwarding Packages

A form sent via email may have a predetermined sequence of recipients.  For example, your expense form might go from you to your manager for approval, to the accounting department for payment, then back to you for confirmation. You can forward a package you have received if:

The form has been sequentially routed

You are not the last recipient on the routing list

You have not already unpacked the form—that is, the form package still exists as a single .FPK file.

To forward a package

1. Open the package in your workspace.

2. Edit the package as required.

3. On the File menu, click Forward Package. The Send Form dialog appears, with the name of the recipients in the Recipients field. Your name appears with an asterisk (*) next to it. The name of the next recipient has an arrow to the left of it.

4. Click OK to send the form.

Returning Packages

A form may be designed to return to the person who originated it. For example, if your Human Resources department does a company survey, they would want all of the filled forms sent back to the same person. The form designer can design a form to do this automatically. You can return a form package you have received to the originator if:

The form was broadcast, or the form was sequentially routed and you are the last recipient on the routing list

You have not already unpacked the form—that is, the form package still exists as a single .FPK file.

To return a package

1. Open the package in your workspace.

2. Edit the package as required.

3. On the File menu, click Return Package. The Send Form dialog appears, with the name of the recipient in the Recipients field.

4. Click OK to send the form.

